Herramientas Ofimáticas en Linux/Vitalinux: LibreOffice

De Vitalinux
Saltar a: navegación, buscar


Herramientas Ofimáticas en Vitalinux

Linux, al igual que Windows, dispone de un paquete de aplicaciones ofimáticas llamado LibreOffice. Es muy importante destacar que LibreOffice es un software libre multiplataforma, lo que significa que esta disponible tanto para Linux como para Windows, por lo que puedes instalarlo en tu equipo Windows sin incurrir en ningún tipo de ilegalidad permitiéndote trabajar de una manera similar a como has hecho hasta ahora con el paquete ofimático de Microsoft: Web de Descargas de LibreOffice.

El paquete ofimático LibreOffice incorpora aplicaciones equivalentes a las comúnmente usadas en Microsoft Office

Para saber más sobre LibreOffice, las aplicaciones que incluye y sus posibilidades se recomienda dirigirse a los siguientes enlaces:


Logobombilla.png

Tarea
5.3

Aplicaciones Ofimáticas. Compatibilidad entre LibreOffice y Microsoft Office

Requisitos: Es necesario haber leído todo lo referente a Herramientas Ofimáticas y disponer de un equipo físico con Vitalinux instalado para realizar la Tarea
Mediante la presente tarea se pretende dar a conocer a LibreOffice como una alternativa de software libre al paquete ofimático de Microsoft (Microsoft Office), tratando de apreciar sus similitudes y compatibilidades, con la finalidad de que el usuario final comprenda que sería una buena opción prescindir del uso de un software privativo que habitualmente se encuentra de manera ilegal en los centros educativos, lo cual es totalmente incomprensible habiendo una alternativa libre.

En concreto, a continuación trataremos comprobaremos la compatibilidad que existe entre ambos paquetes ofimáticos, LibreOffice y Microsoft Office, mediante la apertura y tratamiento de archivos con LibreOffice que han sido creados previamente a través de Microsoft Office:

  • Compatibilidad en LibreOffice Writer con documentos que han sido previamente creados con Microsoft Word:
  1. Localiza algún documento "*.doc" o "*.docx" que haya sido creado con Microsoft Word y guárdalo en el directorio Documentos de tu perfil de Vitalinux
  2. Abre LibreOffice Writer (CONTROL + ESPACIO y teclea Writer), y desde allí abre el documento anterior
  3. Comenta tu impresión respecto a la compatibilidad detectada, y en caso de detectar alguna incompatibilidad, por favor indícala
  4. Realiza alguna modificación en el documento y guarda el documento con formato/extensión "*.doc"/"*.docx". Después ábrelo con Microsoft Word y comprueba la compatibilidad a la inversa
  • Compatibilidad en LibreOffice Calc con documentos que han sido previamente creados con Microsoft Excel:
  1. Localiza algún documento "*.xls" o "*.xlsx" que haya sido creado con Microsoft Excel y guárdalo en el directorio Documentos de tu perfil de Vitalinux (en caso de que no dispongas de ningún documento puedes descargarte el siguiente: Ejemplo de Hoja de Cálculo creada con Microsoft Excel)
  2. Abre LibreOffice Calc (CONTROL + ESPACIO y teclea Calc), y desde allí abre el documento anterior
  3. Comenta tu impresión respecto a la compatibilidad detectada, y en caso de detectar alguna incompatibilidad, por favor indícala
  4. Realiza alguna modificación en el documento y guarda el documento con formato/extensión "*.xls"/"*.xlsx". Después ábrelo con Microsoft Excel y comprueba la compatibilidad a la inversa
  • Compatibilidad en LibreOffice Impress con documentos que han sido previamente creados con Microsoft Power Point:
  1. Localiza algún documento "*.ppt" o "*.pptx" que haya sido creado con Microsoft Point y guárdalo en el directorio Documentos de tu perfil de Vitalinux (en caso de que no dispongas de ningún documento puedes descargarte el siguiente: Ejemplo de presentación PPT creada con Microsoft Power Point)
  2. Abre LibreOffice Impress (CONTROL + ESPACIO y teclea Impress), y desde allí abre el documento anterior
  3. Comenta tu impresión respecto a la compatibilidad detectada, y en caso de detectar alguna incompatibilidad, por favor indícala
  4. Realiza alguna modificación en el documento y guarda el documento con formato/extensión "*.ppt"/"*.pptx". Después ábrelo con Microsoft Power Point y comprueba la compatibilidad a la inversa
¡¡¡Recuerda que "LibreOffice" es "Software Libre"  disponible tanto para Linux como para Windows!!!
¡¡¡Anímate a instalar y usar "LibreOffice" si quieres evitar el uso de software ilegal/pirata tanto en tu casa como en tu centro educativo!!!

Como en ocasiones más vale un buen videotutorial que mil palabras a continuación se sugiere ver el siguiente vídeo relacionado con este asunto:

Formato de Entrega: Si no encuentras muchos problemas para ello, haz algunas capturas de pantalla (tecla IMPRIMIR PANTALLA) de todo lo que vayas haciendo. En caso de encontrar problemas para ello puedes hacer fotos directamente desde el móvil. Elabora un documento ofimático (o usa cualquier otro formato que te resulte más comodo) donde puedas incluir las capturas solicitadas y expórtalo como pdf para adjuntarlo como respuesta a la tarea solicitada. El nombre del fichero deberá seguir la pauta: apellido1_apellido2_nombre_TareaX.pdf.


Logobombilla.png

Tarea
5.4

Aplicaciones Ofimáticas. Extensiones de LibreOffice

Requisitos: Es necesario haber leído todo lo referente a Herramientas Ofimáticas y disponer de un equipo físico con Vitalinux instalado para realizar la Tarea
La característica más importante de LibreOffice es que es Software Libre. Ésto permite su instalación, uso y distribución de manera libre y colaborativa. A consecuencia de todo ello surgen otras características interesantes como la posibilidad de instalar Extensiones creadas por la comunidad de usuarios.

A modo de ejemplo, como tarea se propone instalar al menos una Extensión de LibreOffice:

  1. Abre un navegador Web y accede a la Web de Extensiones Oficiales de LibreOffice: Centro de descargas de Extensiones de LibreOffice
  2. Busca la extensión llamada "MultiFormatSave", descárgala (extensión *.oxt) e instálala (pincha con el botón derecho del ratón sobre el archivo *.oxt descargado e indica que quieres abrirlo con LibreOffice). Esta extensión permitirá a la hora de guardar un documento ofimático, guardarlo simultáneamente en los formatos de LibreOffice (p.e. *.odt), de Microsoft Office (p.e. "*.doc"/"*.docx") y PDF (*.pdf)
  3. A continuación abre por ejemplo LibreOffice Writer, escribe algo y comprueba que en el menú "Archivo" aparece una nueva opción llamada "Multi Save"/"Multi Save As"
  4. Selecciona la opción "Multi Save" e indica que quieres guardar el resultado en un subdirectorio que crearás dentro de Documentos llamado misDocs, eligiendo como nombre para el archivo tu nombre y apellidos (p.e. Arturo_Martin_Romero). ¡¡¡Guárdalo en todos los formatos disponibles!!!

  5. Tras instalar la Extensión MultiFormatSave aparecerá una nueva opción en el menú Archivo permitiéndonos guardar un archivo en varios formatos simultáneamente
  6. Por último, echa un vistazo a la lista de Extensiones disponibles para LibreOffice y comprueba si hay alguna que te puede resultar interesante. En caso afirmativo instálala y comprueba su cometido. Por ejemplo, si haces uso de ecuaciones matemáticas en tus clases la extensión de Libreoffice "TexMaths" es bestial, ya que te permite generar ecuaciones en formato Latex insuperables (¡¡Ojo!! para usar TexMaths necesitarás instalar el programa texlive-latex-base, p.e. a través de synaptic)
¡¡¡Recuerda que "LibreOffice" es "Software Libre"  disponible tanto para Linux como para Windows!!!
¡¡¡Anímate a instalar y usar "LibreOffice" si quieres evitar el uso de software ilegal/pirata tanto en tu casa como en tu centro educativo!!!
Formato de Entrega: Si no encuentras muchos problemas para ello, haz algunas capturas de pantalla (tecla IMPRIMIR PANTALLA) de todo lo que vayas haciendo. En caso de encontrar problemas para ello puedes hacer fotos directamente desde el móvil. Elabora un documento ofimático (o usa cualquier otro formato que te resulte más comodo) donde puedas incluir las capturas solicitadas y expórtalo como pdf para adjuntarlo como respuesta a la tarea solicitada. El nombre del fichero deberá seguir la pauta: apellido1_apellido2_nombre_TareaX.pdf.'


Logobombilla.png

Tarea
5.5

Edición de Archivos PDF

Requisitos: Es necesario haber leído todo lo referente a la instalar y lanzar aplicaciones en Vitalinux y disponer de un equipo con Vitalinux, físico o virtual, para realizar la Tarea
Mediante esta tarea tan sólo se pretende mostrar una herramienta ofimática que puede resultar de utilidad: "un Editor PDF"

Para ello sigue los siguientes pasos:

  1. Con la finalidad de usar un documento de partida común para todos, descarga el siguiente archivo PDF de ejmplo: [1]
  2. Lanza el editor PDF que viene incorporado en Vitalinux: CONTROL + ESPACIO y escribes Master PDF Editor (en caso de no tenerlo instalado deberás lanzar synaptic e instalar el paquete master-pdf-editor3)
  3. En el caso de que los menús del Master PDF Editor no aparezcan en Español deberás ir al menú de la aplicación "Tools"-"Settings" y buscar la opción que permite configurar el Language del programa
  4. Accede al menú "Herramientas/Tools" y selecciona la opción de "Editar Texto". A continuación cambia al menos uno de los títulos principales del documento.
Formato de Entrega: Si no encuentras muchos problemas para ello, haz capturas de pantalla (tecla IMPRIMIR PANTALLA) de todo lo que vayas haciendo. En caso de encontrar problemas para ello puedes hacer fotos directamente desde el móvil. Elabora un documento ofimático (o usa cualquier otro formato que te resulte más comodo) donde puedas incluir las capturas solicitadas y expórtalo como pdf para adjuntarlo como respuesta a la tarea solicitada. El nombre del fichero deberá seguir la pauta: apellido1_apellido2_nombre_TareaX.pdf. Si lo consideras necesario puedes indicar cualquier comentario a las capturas de pantalla.